RUDE

Не могу установить зависимости из-за конфликта версий узла и веб-пакета

Я пытаюсь установить зависимости с точной версией, указанной в файле json, и получаю следующие ошибки:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! Found: webpack@4.46.0
npm ERR! node_modules/webpack
npm ERR!   webpack@"^4.35.3" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer webpack@"^5.1.0" from terser-webpack-plugin@5.3.1
npm ERR! node_modules/terser-webpack-plugin
npm ERR!   dev terser-webpack-plugin@"^5.1.1" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

Поскольку зависимости с требуемой версией не являются последними, я понижаю свой node.js с последней версии 16 до 14+ и устанавливаю с помощью npm i --leacy-peer-deps, но ошибка все равно отображается, кажется версия из узла или веб-пакета по-прежнему несовместима с зависимостями (найдено: webpack@4.46.0 нпм ОШИБКА! node_modules/веб-пакет нпм ОШИБКА! webpack@"^4.35.3" из корневого проекта).

Как я могу решить эту проблему?

Вот список json:

{
  "name": "example-project",
  "version": "1.0.0",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "node src/server/index.js",
    "build-prod": "webpack --config webpack.prod.js",
    "build-dev": "webpack-dev-server  --config webpack.dev.js --open"
  },
  "keywords": [],
  "author": "",
  "license": "ISC",
  "description": "",
  "dependencies": {
    "dotenv": "^8.2.0",
    "express": "^4.17.1",
    "jest-fetch-mock": "^3.0.3",
    "webpack": "^4.35.3",
    "webpack-cli": "^3.3.5"
  },
  "devDependencies": {
    "@babel/core": "^7.13.15",
    "@babel/plugin-transform-modules-commonjs": "^7.13.8",
    "@babel/preset-env": "^7.13.15",
    "babel-loader": "^8.2.2",
    "body-parser": "^1.19.0",
    "clean-webpack-plugin": "^3.0.0",
    "cors": "^2.8.5",
    "css-loader": "^5.2.1",
    "html-webpack-plugin": "^3.2.0",
    "jest": "^26.6.3",
    "mini-css-extract-plugin": "^1.4.1",
    "node-fetch": "^2.6.1",
    "node-sass": "^5.0.0",
    "optimize-css-assets-webpack-plugin": "^5.0.4",
    "sass": "^1.32.8",
    "sass-loader": "^10.1.1",
    "style-loader": "^2.0.0",
    "terser-webpack-plugin": "^5.1.1",
    "webpack-dev-server": "^3.11.2",
    "workbox-webpack-plugin": "^6.1.5"
  }
}

1
32
1

Ответ:

Решено

Попробуйте удалить package-lock.json и очистить кеш npm, используя 'npm cache clean -f' перед npm i.

Обозначение Caret (^): оно обновит вас до всех будущих младших версий/исправлений без увеличения основной версии. ^ 2.3.4 будут использоваться версии с 2.3.4 по <3.0.0.

Тильда ( ~ ): он обновит вас до всех будущих версий патчей, не увеличивая младшую версию. ~1.2.3 будет использовать версии от 1.2.3 до <1.3.